CVE-2019-10130

Priority
Description
A vulnerability was found in PostgreSQL versions 11.x up to excluding 11.3,
10.x up to excluding 10.8, 9.6.x up to, excluding 9.6.13, 9.5.x up to,
excluding 9.5.17. PostgreSQL maintains column statistics for tables.
Certain statistics, such as histograms and lists of most common values,
contain values taken from the column. PostgreSQL does not evaluate row
security policies before consulting those statistics during query planning;
an attacker can exploit this to read the most common values of certain
columns. Affected columns are those for which the attacker has SELECT
privilege and for which, in an ordinary query, row-level security prunes
the set of rows visible to the attacker.
Notes
Package
Upstream:released (10.8)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):released (10.8-0ubuntu0.18.04.1)
Package
Upstream:released (11.3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):not-affected
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):not-affected
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Package
Upstream:released (9.5.17)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (9.5.17-0ubuntu0.16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):DNE
More Information

Updated: 2020-07-28 20:05:58 UTC (commit d26b6ca9f5b3adb89bb036ce73ae7dab894935ec)