CVE-2019-1010319 (retired)

Priority
Description
WavPack 5.1.0 and earlier is affected by: CWE-457: Use of Uninitialized
Variable. The impact is: Unexpected control flow, crashes, and segfaults.
The component is: ParseWave64HeaderConfig (wave64.c:211). The attack vector
is: Maliciously crafted .wav file. The fixed version is: After commit
https://github.com/dbry/WavPack/commit/33a0025d1d63ccd05d9dbaa6923d52b1446a62fe.
Assigned-to
leosilva
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (code not present)
Ubuntu 18.04 LTS (Bionic Beaver):released (5.1.0-2ubuntu1.4)
Ubuntu 18.10 (Cosmic Cuttlefish):ignored (reached end-of-life)
Ubuntu 19.04 (Disco Dingo):released (5.1.0-5ubuntu0.2)
Ubuntu 19.10 (Eoan):not-affected (5.0.1-7)
More Information

Updated: 2019-07-18 17:45:12 UTC (commit 649f8c6455205380e35ed054e9ea734222c716bb)