CVE-2019-10092

Priority
Description
Apache: Limited cross-site scripting in mod_proxy. A limited
cross-site scripting issue was reported affecting the mod_proxy
error page. An attacker could cause the link on the error page to be
malfomed and instead point to a page of their choice. This would only
be exploitable where a server was set up with proxying enabled but was
misconfigured in such a way that the Proxy Error page was displayed.
Notes
 sbeattie> all 2.4.x up to 2.4.41
 sbeattie> first two upstream patches are hardening
Package
Upstream:released (2.4.41-1)
Ubuntu 12.04 ESM (Precise Pangolin):needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):released (2.4.18-2ubuntu3.12)
Ubuntu 18.04 LTS (Bionic Beaver):released (2.4.29-1ubuntu4.10)
Ubuntu 19.04 (Disco Dingo):released (2.4.38-2ubuntu2.2)
Ubuntu 19.10 (Eoan):not-affected (2.4.41-1ubuntu1)
Patches:
Upstream:https://github.com/apache/httpd/commit/b5aa97e7c9792ba31055507eaf9a54e1fbb17464
Upstream:https://github.com/apache/httpd/commit/7106a941f8086e06d4c1b26a8dd6d2a4695eee5a
Upstream:https://github.com/apache/httpd/commit/0522155a5a0fb5ba3b5716a63a3c2253aa74085e
More Information

Updated: 2019-09-19 14:49:55 UTC (commit d32ebc32606b9517c6fa7d65a15441e2a57a6de5)