CVE-2019-1000018

Priority
Description
rssh version 2.3.4 contains a CWE-77: Improper Neutralization of Special
Elements used in a Command ('Command Injection') vulnerability in allowscp
permission that can result in Local command execution. This attack appear
to be exploitable via An authorized SSH user with the allowscp permission.
Notes
 sbeattie> this fix introduced a regression, see debian bug
Package
Source: rssh (LP Ubuntu Debian)
Upstream:released (2.3.4-9)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (2.3.4-4+deb8u2build0.14.04.1)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.3.4-4+deb8u2build0.16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 18.10 (Cosmic Cuttlefish):needed
Ubuntu 19.04 (Disco Dingo):not-affected (2.3.4-10)
More Information

Updated: 2019-03-19 11:32:17 UTC (commit 15472795df7e9de45b82f2d36b8b419b939f97b2)