CVE-2018-8788

Priority
Description
FreeRDP prior to version 2.0.0-rc4 contains an Out-Of-Bounds Write of up to
4 bytes in function nsc_rle_decode() that results in a memory corruption
and possibly even a remote code execution.
Assigned-to
amurray
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.3)
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 18.10 (Cosmic Cuttlefish):needs-triage
Ubuntu 19.04 (Disco Dingo):needs-triage
Package
Upstream:released (2.0.0~git20181120.1.e21b72c95+dfsg1-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):released (2.0.0~git20170725.1.1648deb+dfsg1-7ubuntu0.1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (2.0.0~git20180411.1.7a7b1802+dfsg1-2ubuntu0.1)
Ubuntu 19.04 (Disco Dingo):released (2.0.0~git20181120.1.e21b72c95+dfsg1-1)
More Information

Updated: 2019-01-14 21:33:27 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)