CVE-2018-8787

Priority
Description
FreeRDP prior to version 2.0.0-rc4 contains an Integer Overflow that leads
to a Heap-Based Buffer Overflow in function gdi_Bitmap_Decompress() and
results in a memory corruption and probably even a remote code execution.
Assigned-to
amurray
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [1.0.2-2ubuntu1.2])
Ubuntu 16.04 LTS (Xenial Xerus):released (1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.3)
Ubuntu 18.04 LTS (Bionic Beaver):released (1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1)
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan Ermine):DNE
Package
Upstream:released (2.0.0~git20181120.1.e21b72c95+dfsg1-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):released (2.0.0~git20170725.1.1648deb+dfsg1-7ubuntu0.1)
Ubuntu 19.04 (Disco Dingo):released (2.0.0~git20181120.1.e21b72c95+dfsg1-1)
Ubuntu 19.10 (Eoan Ermine):released (2.0.0~git20181120.1.e21b72c95+dfsg1-1)
More Information

Updated: 2019-12-05 21:09:31 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)