CVE-2018-7584

Priority
Description
In PHP through 5.6.33, 7.0.x before 7.0.28, 7.1.x through 7.1.14, and 7.2.x
through 7.2.2, there is a stack-based buffer under-read while parsing an
HTTP response in the php_stream_url_wrap_http_ex function in
ext/standard/http_fopen_wrapper.c. This subsequently results in copying a
large string.
Notes
Package
Source: php5 (LP Ubuntu Debian)
Upstream:released (5.6.34)
Ubuntu 12.04 ESM (Precise Pangolin):released (5.3.10-1ubuntu3.30)
Ubuntu 14.04 ESM (Trusty Tahr):released (5.5.9+dfsg-1ubuntu4.24)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Package
Upstream:released (7.0.28)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (7.0.28-0ubuntu0.16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Package
Upstream:released (7.1.15)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Package
Upstream:released (7.2.3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):released (7.2.3-1ubuntu1)
Patches:
Upstream:https://github.com/php/php-src/commit/523f230c831d7b33353203fa34aee4e92ac12bba
More Information

Updated: 2019-12-05 18:51:25 UTC (commit dd38ff22974aae499eb50644b9d5a2817483cbdb)