CVE-2018-7569

Priority
Description
dwarf2.c in the Binary File Descriptor (BFD) library (aka libbfd), as
distributed in GNU Binutils 2.30, allows remote attackers to cause a denial
of service (integer underflow or overflow, and application crash) via an
ELF file with a corrupt DWARF FORM block, as demonstrated by nm.
Notes
Package
Upstream:released (2.30-6)
Ubuntu 12.04 ESM (Precise Pangolin):needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.30-21ubuntu1~18.04.1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.31.1-6ubuntu1)
Ubuntu 19.10 (Eoan):not-affected (2.31.1-6ubuntu1)
Patches:
Upstream:https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=12c963421d045a127c413a0722062b9932c50aa9
More Information

Updated: 2019-10-09 06:49:16 UTC (commit 33aea848a182c0afcd0a3f927a01a7ecd9a061ee)