CVE-2018-6003

Priority
Medium
Description
An issue was discovered in the _asn1_decode_simple_ber function in
decoding.c in GNU Libtasn1 before 4.13. Unlimited recursion in the BER
decoder leads to stack exhaustion and DoS.
References
Notes
 leosilva> libtasn1-3 (precise) and libtasn1-6 (trusty) are not affected
 leosilva> since vulnerable code was introduced in 4.3
 leosilva> bionic already has the fix
Assigned-to
leosilva
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):not-affected
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.10 (Artful Aardvark):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Package
Upstream:released (4.13-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):not-affected
Ubuntu 16.04 LTS (Xenial Xerus):released (4.7-3ubuntu0.16.04.3)
Ubuntu 17.10 (Artful Aardvark):released (4.12-2.1ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
More Information

Updated: 2018-06-26 05:03:08 UTC (commit 7799c934cca373482531a7b00e4dfe82302ceae5)