CVE-2018-5764

Priority
Description
The parse_arguments function in options.c in rsyncd in rsync before 3.1.3
does not prevent multiple --protect-args uses, which allows remote
attackers to bypass an argument-sanitization protection mechanism.
Assigned-to
leosilva
Notes
leosilvafor precise/esm code is slightly different.
Package
Source: rsync (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):released (3.0.9-1ubuntu1.3)
Ubuntu 14.04 ESM (Trusty Tahr):released (3.1.0-2ubuntu0.4)
Ubuntu 16.04 LTS (Xenial Xerus):released (3.1.1-3ubuntu1.2)
Ubuntu 18.04 LTS (Bionic Beaver):released (3.1.2-2.1ubuntu1)
More Information

Updated: 2020-09-10 05:59:00 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)