CVE-2018-5186

Priority
Description
Memory safety bugs present in Firefox 60. Some of these bugs showed
evidence of memory corruption and we presume that with enough effort that
some of these could be exploited to run arbitrary code. This vulnerability
affects Firefox < 61.
Notes
 tyhicks> mozjs contains a copy of the SpiderMonkey JavaScript engine
Assigned-to
chrisccoulson
Package
Upstream:released (61.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [61.0+build3-0ubuntu0.14.04.2])
Ubuntu 16.04 LTS (Xenial Xerus):released (61.0+build3-0ubuntu0.16.04.2)
Ubuntu 18.04 LTS (Bionic Beaver):released (61.0+build3-0ubuntu0.18.04.1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (61.0.1+build1-0ubuntu0.18.04.1)
Ubuntu 19.04 (Disco Dingo):released (61.0.1+build1-0ubuntu0.18.04.1)
Ubuntu 19.10 (Eoan):released (61.0.1+build1-0ubuntu0.18.04.1)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 18.10 (Cosmic Cuttlefish):ignored (reached end-of-life)
Ubuntu 19.04 (Disco Dingo):needs-triage
Ubuntu 19.10 (Eoan):needs-triage
More Information

Updated: 2019-07-18 17:37:01 UTC (commit 649f8c6455205380e35ed054e9ea734222c716bb)