CVE-2018-5129

Priority
Description
A lack of parameter validation on IPC messages results in a potential
out-of-bounds write through malformed IPC messages. This can potentially
allow for sandbox escape through memory corruption in the parent process.
This vulnerability affects Thunderbird < 52.7, Firefox ESR < 52.7, and
Firefox < 59.
Assigned-to
chrisccoulson
Notes
Package
Upstream:released (59.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [59.0+build5-0ubuntu0.14.04.1])
Ubuntu 16.04 LTS (Xenial Xerus):released (59.0+build5-0ubuntu0.16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (59.0.1+build1-0ubuntu1)
Package
Priority: Low
Upstream:released (52.7.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [1:52.7.0+build1-0ubuntu0.14.04.1])
Ubuntu 16.04 LTS (Xenial Xerus):released (1:52.7.0+build1-0ubuntu0.16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (1:52.7.0+build1-0ubuntu1)
More Information

Updated: 2019-12-05 18:50:57 UTC (commit dd38ff22974aae499eb50644b9d5a2817483cbdb)