CVE-2018-5090

Priority
Medium
Description
Memory safety bugs were reported in Firefox 57. Some of these bugs showed
evidence of memory corruption and we presume that with enough effort that
some of these could be exploited to run arbitrary code. This vulnerability
affects Firefox < 58.
References
Notes
 tyhicks> mozjs contains a copy of the SpiderMonkey JavaScript engine
 chrisccoulson> This is not fixed in mozjs52, but it's unclear whether it is
  unaffected or just ignored as the bugs are still private. Specifically, the
  following need investigating:
  - https://bugzilla.mozilla.org/show_bug.cgi?id=1412653
  (https://hg.mozilla.org/releases/mozilla-release/rev/935393b713cb)
  - https://bugzilla.mozilla.org/show_bug.cgi?id=1418966
  (https://hg.mozilla.org/releases/mozilla-release/rev/32bb2e9efd34)
  - https://bugzilla.mozilla.org/show_bug.cgi?id=1427126
  (https://hg.mozilla.org/releases/mozilla-release/rev/3e7bec52b143)
  - https://bugzilla.mozilla.org/show_bug.cgi?id=1382851 (can't find a changeset
  referencing it)
  - https://bugzilla.mozilla.org/show_bug.cgi?id=1421786 (can't find a changeset
  referencing it)
  - https://bugzilla.mozilla.org/show_bug.cgi?id=1415748 (can't find a changeset
  referencing it)
  - https://bugzilla.mozilla.org/show_bug.cgi?id=1415788 (can't find a changeset
  referencing it)
  - https://bugzilla.mozilla.org/show_bug.cgi?id=1418841
  (https://hg.mozilla.org/releases/mozilla-release/rev/f24456236534)
  - https://bugzilla.mozilla.org/show_bug.cgi?id=1384544
  (https://hg.mozilla.org/releases/mozilla-release/rev/971c6a19e3b5)
Assigned-to
chrisccoulson
Package
Upstream:released (58.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (58.0+build6-0ubuntu0.14.04.1)
Ubuntu 16.04 LTS (Xenial Xerus):released (58.0+build6-0ubuntu0.16.04.1)
Ubuntu 17.10 (Artful Aardvark):released (58.0+build6-0ubuntu0.17.10.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (59.0.1+build1-0ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (59.0.1+build1-0ubuntu1)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.10 (Artful Aardvark):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 18.10 (Cosmic Cuttlefish):needs-triage
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.10 (Artful Aardvark):deferred
Ubuntu 18.04 LTS (Bionic Beaver):deferred
Ubuntu 18.10 (Cosmic Cuttlefish):deferred
More Information

Updated: 2018-06-13 17:14:33 UTC (commit 14944)