There is a possible XSS vulnerability in all rails-html-sanitizer gem
versions below 1.0.4 for Ruby. The gem allows non-whitelisted attributes to
be present in sanitized output when input with specially-crafted HTML
fragments, and these attributes can lead to an XSS attack on target
applications. This issue is similar to CVE-2018-8048 in Loofah. All users
running an affected release should either upgrade or use one of the
workarounds immediately.
Upstream:released (1.0.4)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.0.4-1)
Ubuntu 19.10 (Eoan Ermine):not-affected (1.0.4-1)
Ubuntu 20.04 (Focal Fossa):not-affected (1.0.4-1)
More Information

Updated: 2020-01-29 18:55:06 UTC (commit 40f18bf14da5fb50662e1f861ea594a462b207fe)