CVE-2018-2634

Priority
Medium
Description
Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE
(subcomponent: JGSS). Supported versions that are affected are Java SE:
7u161, 8u152 and 9.0.1; Java SE Embedded: 8u151. Difficult to exploit
vulnerability allows unauthenticated attacker with network access via
multiple protocols to compromise Java SE, Java SE Embedded. While the
vulnerability is in Java SE, Java SE Embedded, attacks may significantly
impact additional products. Successful attacks of this vulnerability can
result in unauthorized access to critical data or complete access to all
Java SE, Java SE Embedded accessible data. Note: This vulnerability applies
to Java deployments, typically in clients running sandboxed Java Web Start
applications or sandboxed Java applets, that load and run untrusted code
(e.g., code that comes from the internet) and rely on the Java sandbox for
security. This vulnerability does not apply to Java deployments, typically
in servers, that load and run only trusted code (e.g., code installed by an
administrator). CVSS 3.0 Base Score 6.8 (Confidentiality impacts). CVSS
Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N).
Ubuntu-Description
It was discovered that the Java GSS implementation in OpenJDK in some
situations did not properly apply subject credentials. An attacker
could possibly use this to expose sensitive information or gain
access to unauthorized resources.
References
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (7u171-2.6.13-0ubuntu0.14.04.2)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.10 (Artful Aardvark):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.10 (Artful Aardvark):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 17.10 (Artful Aardvark):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (9.0.4+12-1)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (8u162-b12-0ubuntu0.16.04.2)
Ubuntu 17.10 (Artful Aardvark):released (8u162-b12-0ubuntu0.17.10.2)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (8u162-b12-1)
Patches:
Upstream:http://hg.openjdk.java.net/jdk8u/jdk8u/jdk/rev/54545fe8a16c
More Information

Updated: 2018-04-18 07:14:25 UTC (commit 14580)