CVE-2018-20749

Priority
Description
LibVNC before 0.9.12 contains a heap out-of-bounds write vulnerability in
libvncserver/rfbserver.c. The fix for CVE-2018-15127 was incomplete.
Assigned-to
mdeslaur
Package
Upstream:released (0.9.11+dfsg-1.3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (0.9.9+dfsg-1ubuntu1.4)
Ubuntu 16.04 LTS (Xenial Xerus):released (0.9.10+dfsg-3ubuntu0.16.04.3)
Ubuntu 18.04 LTS (Bionic Beaver):released (0.9.11+dfsg-1ubuntu1.1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (0.9.11+dfsg-1.1ubuntu0.1)
Ubuntu 19.04 (Disco Dingo):not-affected (0.9.11+dfsg-1.3)
Patches:
Upstream:https://github.com/LibVNC/libvncserver/commit/15bb719c03cc70f14c36a843dcb16ed69b405707
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 18.10 (Cosmic Cuttlefish):needs-triage
Ubuntu 19.04 (Disco Dingo):needs-triage
More Information

Updated: 2019-01-31 21:14:21 UTC (commit 2e0d8cdedda47ef96c2828bef37192f5d5eeb000)