CVE-2018-20712

Priority
Description
A heap-based buffer over-read exists in the function d_expression_1 in
cp-demangle.c in GNU libiberty, as distributed in GNU Binutils 2.31.1. A
crafted input can cause segmentation faults, leading to denial-of-service,
as demonstrated by c++filt.
Notes
 mdeslaur> as of 2019-01-21, no fix available
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):deferred (2019-01-21)
Ubuntu 16.04 LTS (Xenial Xerus):deferred (2019-01-21)
Ubuntu 18.04 LTS (Bionic Beaver):deferred (2019-01-21)
Ubuntu 18.10 (Cosmic Cuttlefish):deferred (2019-01-21)
Ubuntu 19.04 (Disco Dingo):deferred (2019-01-21)
More Information

Updated: 2019-03-19 11:30:29 UTC (commit 15472795df7e9de45b82f2d36b8b419b939f97b2)