CVE-2018-20699 (retired)

Priority
Description
Docker Engine before 18.09 allows attackers to cause a denial of service
(dockerd memory consumption) via a large integer in a --cpuset-mems or
--cpuset-cpus value, related to daemon/daemon_unix.go,
pkg/parsers/parsers.go, and pkg/sysinfo/sysinfo.go.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was deferred)
Ubuntu 16.04 LTS (Xenial Xerus):released (18.09.2-0ubuntu1~16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (18.09.2-0ubuntu1~18.04.1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (18.09.2-0ubuntu1~18.10.1)
Ubuntu 19.04 (Disco Dingo):released (18.09.2-0ubuntu1)
Ubuntu 19.10 (Eoan):released (18.09.2-0ubuntu1)
Patches:
Other:https://github.com/docker/engine/pull/70
Other:https://github.com/moby/moby/pull/37967
More Information

Updated: 2019-06-17 14:14:54 UTC (commit 3e6d9703f811d0853267c7c3a5bc8ea9156fdf9c)