CVE-2018-20506

Priority
Description
SQLite before 3.25.3, when the FTS3 extension is enabled, encounters an
integer overflow (and resultant buffer overflow) for FTS3 queries in a
"merge" operation that occurs after crafted changes to FTS3 shadow tables,
allowing remote attackers to execute arbitrary code by leveraging the
ability to run arbitrary SQL statements (such as in certain WebSQL use
cases). This is a different vulnerability than CVE-2018-20346.
Notes
Package
Upstream:released (3.25.3-1)
Ubuntu 12.04 ESM (Precise Pangolin):released (3.7.9-2ubuntu1.3)
Ubuntu 14.04 ESM (Trusty Tahr):released (3.8.2-1ubuntu2.2+esm1)
Ubuntu 16.04 LTS (Xenial Xerus):released (3.11.0-1ubuntu1.2)
Ubuntu 18.04 LTS (Bionic Beaver):released (3.22.0-1ubuntu0.1)
Ubuntu 19.04 (Disco Dingo):not-affected (3.27.2-1)
Ubuntu 19.10 (Eoan Ermine):not-affected (3.27.2-1)
More Information

Updated: 2019-12-05 21:09:24 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)