CVE-2018-19497

Priority
Description
In The Sleuth Kit (TSK) through 4.6.4, hfs_cat_traverse in tsk/fs/hfs.c
does not properly determine when a key length is too large, which allows
attackers to cause a denial of service (SEGV on unknown address with READ
memory access in a tsk_getu16 call in hfs_dir_open_meta_cb in
tsk/fs/hfs_dent.c).
Notes
 ebarretto> It looks like the versions in trusty and xenial are not
 ebarretto> affected.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):not-affected
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 18.10 (Cosmic Cuttlefish):needed
Ubuntu 19.04 (Disco Dingo):needed
More Information

Updated: 2019-01-14 21:31:16 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)