CVE-2018-19107

Priority
Description
In Exiv2 0.26, Exiv2::IptcParser::decode in iptc.cpp (called from
psdimage.cpp in the PSD image reader) may suffer from a denial of service
(heap-based buffer over-read) caused by an integer overflow via a crafted
PSD image file.
Notes
mdeslaur1-byte invalid read
Package
Source: exiv2 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):released (0.25-2.1ubuntu16.04.4)
Ubuntu 18.04 LTS (Bionic Beaver):released (0.25-3.1ubuntu0.18.04.3)
Patches:
Upstream:https://github.com/Exiv2/exiv2/commit/68966932510213b5656fcf433ab6d7e26f48e23b
Upstream:https://github.com/Exiv2/exiv2/commit/b7c71f3ad0386cd7af3b73443c0615ada073f0d5
More Information

Updated: 2020-09-10 05:54:40 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)