CVE-2018-18849

Priority
Description
In Qemu 3.0.0, lsi_do_msgin in hw/scsi/lsi53c895a.c allows out-of-bounds
access by triggering an invalid msg_len value.
Assigned-to
mdeslaur
Package
Source: qemu (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (2.0.0+dfsg-2ubuntu1.44)
Ubuntu 16.04 LTS (Xenial Xerus):released (1:2.5+dfsg-5ubuntu10.33)
Ubuntu 18.04 LTS (Bionic Beaver):released (1:2.11+dfsg-1ubuntu7.8)
Ubuntu 18.10 (Cosmic Cuttlefish):released (1:2.12+dfsg-3ubuntu8.1)
Ubuntu 19.04 (Disco Dingo):released (1:2.12+dfsg-3ubuntu9)
Patches:
Other:https://lists.gnu.org/archive/html/qemu-devel/2018-10/msg06682.html
Upstream:https://git.qemu.org/?p=qemu.git;a=commit;h=e58ccf039650065a9442de43c9816f81e88f27f6
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
More Information

Updated: 2019-03-21 02:14:21 UTC (commit 4ab68c52e64fb8069eb30ad125eaa59c21ae8843)