CVE-2018-18651

Priority
Description
An issue was discovered in Xpdf 4.00. catalog->getNumPages() in AcroForm.cc
allows attackers to launch a denial of service (hang caused by large loop)
via a specific pdf file, as demonstrated by pdftohtml. This is mainly
caused by a large number after the /Count field in the file.
Notes
jdstrandxpdf in koffice is 2.0
mdeslaurno indication this affects poppler
Package
Source: ipe (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needs-triage)
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 19.10 (Eoan Ermine):needs-triage
Ubuntu 20.04 (Focal Fossa):needs-triage
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needs-triage)
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 19.10 (Eoan Ermine):needs-triage
Ubuntu 20.04 (Focal Fossa):needs-triage
Package
Upstream:not-affected (poppler is not affected)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Ubuntu 19.10 (Eoan Ermine):not-affected
Ubuntu 20.04 (Focal Fossa):not-affected
Package
Source: xpdf (LP Ubuntu Debian)
Upstream:not-affected (debian: xpdf in Debian uses poppler, which is not affected or fixed)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needs-triage)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (3.03-17)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (3.04-7)
Ubuntu 19.10 (Eoan Ermine):not-affected (3.04-13)
Ubuntu 20.04 (Focal Fossa):DNE
More Information

Updated: 2020-04-24 03:48:50 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)