CVE-2018-18505

Priority
Description
An earlier fix for an Inter-process Communication (IPC) vulnerability,
CVE-2011-3079, added authentication to communication between IPC endpoints
and server parents during IPC process creation. This authentication is
insufficient for channels created after the IPC process is started, leading
to the authentication not being correctly applied to later channels. This
could allow for a sandbox escape through IPC channels due to lack of
message validation in the listener process. This vulnerability affects
Thunderbird < 60.5, Firefox ESR < 60.5, and Firefox < 65.
Assigned-to
chrisccoulson
Notes
tyhicksmozjs contains a copy of the SpiderMonkey JavaScript engine
Package
Upstream:released (65.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [65.0+build2-0ubuntu0.14.04.1])
Ubuntu 16.04 LTS (Xenial Xerus):released (65.0+build2-0ubuntu0.16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (65.0+build2-0ubuntu0.18.04.1)
Ubuntu 19.04 (Disco Dingo):released (65.0+build2-0ubuntu1)
Ubuntu 19.10 (Eoan Ermine):released (65.0+build2-0ubuntu1)
Ubuntu 20.04 (Focal Fossa):released (65.0+build2-0ubuntu1)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan Ermine):DNE
Ubuntu 20.04 (Focal Fossa):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 19.04 (Disco Dingo):needs-triage
Ubuntu 19.10 (Eoan Ermine):needs-triage
Ubuntu 20.04 (Focal Fossa):needs-triage
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.04 (Disco Dingo):needs-triage
Ubuntu 19.10 (Eoan Ermine):needs-triage
Ubuntu 20.04 (Focal Fossa):needs-triage
Package
Priority: Low
Upstream:released (60.5)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [1:60.5.1+build2-0ubuntu0.14.04.1])
Ubuntu 16.04 LTS (Xenial Xerus):released (1:60.5.1+build2-0ubuntu0.16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (1:60.5.1+build2-0ubuntu0.18.04.1)
Ubuntu 19.04 (Disco Dingo):released (1:60.5.1+build2-0ubuntu1)
Ubuntu 19.10 (Eoan Ermine):released (1:60.5.1+build2-0ubuntu1)
Ubuntu 20.04 (Focal Fossa):released (1:60.5.1+build2-0ubuntu1)
More Information

Updated: 2019-12-05 19:54:50 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)