CVE-2018-18312

Priority
Description
Perl before 5.26.3 and 5.28.0 before 5.28.1 has a buffer overflow via a
crafted regular expression that triggers invalid write operations.
Assigned-to
mdeslaur
Notes
upstream5.18 - 5.28
mdeslaurlooks to me like this was introduced by:
https://perl5.git.perl.org/perl.git/commit/6798c95dd27b33efd71f394c18649af7bbaf42b7
trusty doesn't look affected
Package
Source: perl (LP Ubuntu Debian)
Upstream:released (5.28.1-1)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (5.18.2-2ubuntu1.6)
Ubuntu 16.04 LTS (Xenial Xerus):released (5.22.1-9ubuntu0.6)
Ubuntu 18.04 LTS (Bionic Beaver):released (5.26.1-6ubuntu0.3)
More Information

Updated: 2020-09-10 05:54:33 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)