CVE-2018-18311

Priority
Description
Perl before 5.26.3 and 5.28.x before 5.28.1 has a buffer overflow via a
crafted regular expression that triggers invalid write operations.
Assigned-to
mdeslaur
Notes
upstream5.8.0 - 5.26 (introduced in e658793210bb)
Package
Source: perl (LP Ubuntu Debian)
Upstream:released (5.28.1-1)
Ubuntu 12.04 ESM (Precise Pangolin):released (5.14.2-6ubuntu2.9)
Ubuntu 14.04 ESM (Trusty Tahr):released (5.18.2-2ubuntu1.7)
Ubuntu 16.04 LTS (Xenial Xerus):released (5.22.1-9ubuntu0.6)
Ubuntu 18.04 LTS (Bionic Beaver):released (5.26.1-6ubuntu0.3)
Ubuntu 19.04 (Disco Dingo):released (5.28.1-1)
More Information

Updated: 2019-12-05 18:50:44 UTC (commit dd38ff22974aae499eb50644b9d5a2817483cbdb)