CVE-2018-17847 (retired)

Priority
Description
The html package (aka x/net/html) through 2018-09-25 in Go mishandles
<svg><template><desc><t><svg></template>, leading to a "panic: runtime
error" (index out of range) in (*nodeStack).pop in node.go, called from
(*parser).clearActiveFormattingElements, during an html.Parse call.
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (code not present)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (code not present)
Ubuntu 19.04 (Disco Dingo):not-affected (code not present)
Patches:
Upstream:https://github.com/golang/net/commit/4b62a64f59f73840b9ab79204c94fee61cd1ba2c
More Information

Updated: 2019-10-09 08:03:30 UTC (commit 33aea848a182c0afcd0a3f927a01a7ecd9a061ee)