CVE-2018-17244

Priority
Description
Elasticsearch Security versions 6.4.0 to 6.4.2 contain an error in the way
request headers are applied to requests when using the Active Directory,
LDAP, Native, or File realms. A request may receive headers intended for
another request if the same username is being authenticated concurrently;
when used with run as, this can result in the request running as the
incorrect user. This could allow a user to access information that they
should not have access to.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
More Information

Updated: 2019-01-14 21:30:41 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)