CVE-2018-17101

Priority
Description
An issue was discovered in LibTIFF 4.0.9. There are two out-of-bounds
writes in cpTags in tools/tiff2bw.c and tools/pal2rgb.c, which can cause a
denial of service (application crash) or possibly have unspecified other
impact via a crafted image file.
Assigned-to
mdeslaur
Package
Source: tiff (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):needed
Ubuntu 14.04 LTS (Trusty Tahr):released (4.0.3-7ubuntu0.10)
Ubuntu 16.04 LTS (Xenial Xerus):released (4.0.6-1ubuntu0.5)
Ubuntu 18.04 LTS (Bionic Beaver):released (4.0.9-5ubuntu0.1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (4.0.9-6ubuntu0.1)
Ubuntu 19.04 (Disco Dingo):not-affected (4.0.10-3)
Patches:
Upstream:https://gitlab.com/libtiff/libtiff/commit/31374a7bf15a860f679a4b7dcac885e9905076ce
More Information

Updated: 2019-01-22 15:14:25 UTC (commit 0916262c7eb1af6c7d60adbec8c61ec930321744)