CVE-2018-17095

Priority
Description
An issue has been discovered in mpruett Audio File Library (aka audiofile)
0.3.6. A heap-based buffer overflow in Expand3To4Module::run has occurred
when running sfconvert.
Assigned-to
leosilva
Notes
mdeslaurno fix as of 2018-09-18
ebarrettoIt looks like upstream is not active anymore, some of the open CVEs
have a proposed fix on a fork.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):released (0.3.6-2ubuntu0.14.04.3)
Ubuntu 16.04 LTS (Xenial Xerus):deferred (2018-09-18)
Ubuntu 18.04 LTS (Bionic Beaver):deferred (2018-09-18)
Ubuntu 20.04 LTS (Focal Fossa):not-affected (0.3.6-5build1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (0.3.6-5build1)
Patches:
Upstream:https://github.com/wtay/audiofile/commit/822b732fd31ffcb78f6920001e9b1fbd815fa712
More Information

Updated: 2020-07-28 18:50:11 UTC (commit 7b6828437fde0509248708fcdb5b0f7587b85bd1)