CVE-2018-17082 (retired)

Priority
Description
The Apache2 component in PHP before 5.6.38, 7.0.x before 7.0.32, 7.1.x
before 7.1.22, and 7.2.x before 7.2.10 allows XSS via the body of a
"Transfer-Encoding: chunked" request, because the bucket brigade is
mishandled in the php_handler function in
sapi/apache2handler/sapi_apache2.c.
Notes
mdeslaurWhile not mentioned in the USN, the fix for this issue was
included.
Package
Source: php5 (LP Ubuntu Debian)
Upstream:released (5.6.38)
Ubuntu 12.04 ESM (Precise Pangolin):released (5.3.10-1ubuntu3.32)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Patches:
Upstream:https://github.com/php/php-src/commit/23b057742e3cf199612fa8050ae86cae675e214e
Package
Upstream:released (7.0.32)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (7.0.32-0ubuntu0.16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Package
Upstream:released (7.2.10)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):released (7.2.10-0ubuntu0.18.04.1)
More Information

Updated: 2019-10-09 08:03:24 UTC (commit 33aea848a182c0afcd0a3f927a01a7ecd9a061ee)