CVE-2018-16890

Priority
Description
libcurl versions from 7.36.0 to before 7.64.0 is vulnerable to a heap
buffer out-of-bounds read. The function handling incoming NTLM type-2
messages (`lib/vauth/ntlm.c:ntlm_decode_type2_target`) does not validate
incoming data correctly and is subject to an integer overflow
vulnerability. Using that overflow, a malicious or broken NTLM server could
trick libcurl to accept a bad length + offset combination that would lead
to a buffer read out-of-bounds.
Assigned-to
mdeslaur
Notes
mdeslauraffects libcurl 7.36.0 to and including 7.63.0
Package
Source: curl (LP Ubuntu Debian)
Upstream:released (7.64.0)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (code not present)
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):released (7.47.0-1ubuntu2.12)
Ubuntu 18.04 LTS (Bionic Beaver):released (7.58.0-2ubuntu3.6)
More Information

Updated: 2020-09-10 05:54:23 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)