CVE-2018-16881

Priority
Description
A denial of service vulnerability was found in rsyslog in the imptcp
module. An attacker could send a specially crafted message to the imptcp
socket, which would cause rsyslog to crash. Versions before 8.27.0 are
vulnerable.
Notes
 sbeattie> requires imptcp module to be loaded, which is not enabled in
  the default configuration
Package
Upstream:released (8.27.0-2)
Ubuntu 12.04 ESM (Precise Pangolin):needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (8.32.0-1ubuntu4)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected
Ubuntu 19.04 (Disco Dingo):not-affected
Patches:
Upstream:https://github.com/rsyslog/rsyslog/commit/0381a0de64a5a048c3d48b79055bd9848d0c7fc2
More Information

Updated: 2019-03-19 11:29:05 UTC (commit 15472795df7e9de45b82f2d36b8b419b939f97b2)