CVE-2018-16858 (retired)

Priority
Description
It was found that libreoffice before versions 6.0.7 and 6.1.3 was
vulnerable to a directory traversal attack which could be used to execute
arbitrary macros bundled with a document. An attacker could craft a
document, which when opened by LibreOffice, would execute a Python method
from a script in any arbitrary file system location, specified relative to
the LibreOffice install location.
Assigned-to
mdeslaur
Package
Upstream:released (6.0.7/6.1.3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (1:4.2.8-0ubuntu5.5)
Ubuntu 16.04 LTS (Xenial Xerus):released (1:5.1.6~rc2-0ubuntu1~xenial6)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1:6.0.7-0ubuntu0.18.04.2)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1:6.1.4-0ubuntu0.18.10.1)
Ubuntu 19.04 (Disco Dingo):not-affected (1:6.1.4-0ubuntu1)
Patches:
Upstream:https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-6-0&id=b1c85cdb37a47998f8ab135fbc96f186334b171c (6.0)
More Information

Updated: 2019-03-29 02:14:57 UTC (commit 4f84fe790cebaab8768c0c369531aca9c55f7450)