CVE-2018-16850 (retired)

Priority
Description
postgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection
in pg_upgrade and pg_dump via CREATE TRIGGER ... REFERENCING. Using a
purpose-crafted trigger definition, an attacker can cause arbitrary SQL
statements to run, with superuser privileges.
Notes
 mdeslaur> only affects 10.x and 11.x per upstream security page
Package
Upstream:released (10.6)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):released (10.6-0ubuntu0.18.04.1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (10.6-0ubuntu0.18.10.1)
Ubuntu 19.04 (Disco Dingo):DNE
Package
Upstream:not-affected
Ubuntu 12.04 ESM (Precise Pangolin):not-affected
Ubuntu 14.04 LTS (Trusty Tahr):not-affected
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Package
Upstream:not-affected
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):not-affected
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Package
Upstream:not-affected
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
More Information

Updated: 2019-03-26 12:27:12 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)