CVE-2018-16845

Priority
Description
nginx before versions 1.15.6, 1.14.1 has a vulnerability in the
ngx_http_mp4_module, which might allow an attacker to cause infinite loop
in a worker process, cause a worker process crash, or might result in
worker process memory disclosure by using a specially crafted mp4 file. The
issue only affects nginx if it is built with the ngx_http_mp4_module (the
module is not built by default) and the .mp4. directive is used in the
configuration file. Further, the attack is only possible if an attacker is
able to trigger processing of a specially crafted mp4 file with the
ngx_http_mp4_module.
Notes
 mdeslaur> module is built in the nginx-extras package
Assigned-to
mdeslaur
Package
Source: nginx (LP Ubuntu Debian)
Upstream:released (1.15.6)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (1.4.6-1ubuntu3.9)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.10.3-0ubuntu0.16.04.3)
Ubuntu 18.04 LTS (Bionic Beaver):released (1.14.0-0ubuntu1.2)
Ubuntu 18.10 (Cosmic Cuttlefish):released (1.15.5-0ubuntu2.1)
Ubuntu 19.04 (Disco Dingo):released (1.15.6-0ubuntu1)
Patches:
Upstream:http://hg.nginx.org/nginx/rev/e5069816039b
More Information

Updated: 2018-11-15 13:14:46 UTC (commit 20c3495278668bf41f3673bdd453fdc5fb421a1f)