CVE-2018-16843

Priority
Description
nginx before versions 1.15.6 and 1.14.1 has a vulnerability in the
implementation of HTTP/2 that can allow for excessive memory consumption.
This issue affects nginx compiled with the ngx_http_v2_module (not compiled
by default) if the 'http2' option of the 'listen' directive is used in a
configuration file.
Assigned-to
mdeslaur
Package
Source: nginx (LP Ubuntu Debian)
Upstream:released (1.15.6)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.10.3-0ubuntu0.16.04.3)
Ubuntu 18.04 LTS (Bionic Beaver):released (1.14.0-0ubuntu1.2)
Ubuntu 18.10 (Cosmic Cuttlefish):released (1.15.5-0ubuntu2.1)
Ubuntu 19.04 (Disco Dingo):released (1.15.6-0ubuntu1)
Patches:
Upstream:http://hg.nginx.org/nginx/rev/d4448892a294
More Information

Updated: 2018-11-15 13:14:45 UTC (commit 20c3495278668bf41f3673bdd453fdc5fb421a1f)