CVE-2018-16842

Priority
Description
Curl versions 7.14.1 through 7.61.1 are vulnerable to a heap-based buffer
over-read in the tool_msgs.c:voutf() function that may result in
information exposure and denial of service.
Assigned-to
mdeslaur
Package
Source: curl (LP Ubuntu Debian)
Upstream:pending (7.62.0)
Ubuntu 12.04 ESM (Precise Pangolin):released (7.22.0-3ubuntu4.24)
Ubuntu 14.04 LTS (Trusty Tahr):released (7.35.0-1ubuntu2.19)
Ubuntu 16.04 LTS (Xenial Xerus):released (7.47.0-1ubuntu2.11)
Ubuntu 18.04 LTS (Bionic Beaver):released (7.58.0-2ubuntu3.5)
Ubuntu 18.10 (Cosmic Cuttlefish):released (7.61.0-1ubuntu2.2)
Ubuntu 19.04 (Disco Dingo):released (7.61.0-1ubuntu2.2)
More Information

Updated: 2019-03-19 12:30:36 UTC (commit 15472795df7e9de45b82f2d36b8b419b939f97b2)