CVE-2018-16395

Priority
Description
An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x
before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3. When two
OpenSSL::X509::Name objects are compared using ==, depending on the
ordering, non-equal objects may return true. When the first argument is one
character longer than the second, or the second argument contains a
character that is one less than a character in the same position of the
first argument, the result of == will be true. This could be leveraged to
create an illegitimate certificate that may be accepted as legitimate and
then used in signing or encryption operations.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 18.10 (Cosmic Cuttlefish):needs-triage
Ubuntu 19.04 (Disco Dingo):needs-triage
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (1.9.3.484-2ubuntu1.13)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (2.0.0.484-1ubuntu2.11)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Patches:
Upstream:https://github.com/ruby/openssl/commit/f653cfa43f0f20e8c440122ea982382b6228e7f5
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (2.3.1-2~16.04.11)
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):released (2.5.1-1ubuntu1.1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (2.5.1-5ubuntu4.1)
Ubuntu 19.04 (Disco Dingo):released (2.5.1-6ubuntu3)
More Information

Updated: 2018-11-21 19:14:22 UTC (commit 64f6fc0c030cd1aaeb5ed7b94af5fa9f801dfaa6)