CVE-2018-16393

Priority
Description
Several buffer overflows when handling responses from a Gemsafe V1
Smartcard in gemsafe_get_cert_len in libopensc/pkcs15-gemsafeV1.c in OpenSC
before 0.19.0-rc1 could be used by attackers able to supply crafted
smartcards to cause a denial of service (application crash) or possibly
have unspecified other impact.
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needs-triage)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 19.10 (Eoan Ermine):not-affected (0.19.0-1build1)
Ubuntu 20.04 (Focal Fossa):not-affected (0.19.0-1build1)
Patches:
Other:https://github.com/OpenSC/OpenSC/commit/360e95d45ac4123255a4c796db96337f332160ad
More Information

Updated: 2020-04-24 03:48:10 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)