CVE-2018-16323

Priority
Description
ReadXBMImage in coders/xbm.c in ImageMagick before 7.0.8-9 leaves data
uninitialized when processing an XBM file that has a negative pixel value.
If the affected code is used as a library loaded into a process that
includes sensitive information, that information sometimes can be leaked
via the image data.
Package
Upstream:released (6.9.10-9)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:DNE (trusty was released [8:6.7.7.10-6ubuntu3.13])
Ubuntu 16.04 LTS (Xenial Xerus):released (8:6.8.9.9-7ubuntu5.13)
Ubuntu 18.04 LTS (Bionic Beaver):released (8:6.9.7.4+dfsg-16ubuntu6.4)
Ubuntu 18.10 (Cosmic Cuttlefish):needed
Ubuntu 19.04 (Disco Dingo):not-affected (8:6.9.10.14+dfsg-7ubuntu2)
Ubuntu 19.10 (Eoan):not-affected (8:6.9.10.14+dfsg-7ubuntu2)
Patches:
Upstream:https://github.com/ImageMagick/ImageMagick/commit/216d117f05bff87b9dc4db55a1b1fadb38bcb786
Upstream:https://github.com/ImageMagick/ImageMagick6/commit/57565dace66d550042522e203f522da711d551a6
More Information

Updated: 2019-04-26 14:27:05 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)