CVE-2018-16140

Priority
Description
A buffer underwrite vulnerability in get_line() (read.c) in fig2dev 3.2.7a
allows an attacker to write prior to the beginning of the buffer via a
crafted .fig file.
Assigned-to
leosilva
Package
Upstream:released (1:3.2.7a-3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 18.10 (Cosmic Cuttlefish):needs-triage
Ubuntu 19.04 (Disco Dingo):needs-triage
Patches:
Other:https://sourceforge.net/p/mcj/fig2dev/ci/e0c4b02429116b15ad1568c2c425f06b95b95830
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (1:3.2.5.e-1ubuntu1.1)
Ubuntu 16.04 LTS (Xenial Xerus):released (1:3.2.5.e-5ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
More Information

Updated: 2019-01-14 21:30:22 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)