CVE-2018-14681

Priority
Description
An issue was discovered in kwajd_read_headers in mspack/kwajd.c in
libmspack before 0.7alpha. Bad KWAJ file header extensions could cause a
one or two byte overwrite.
Assigned-to
leosilva
Notes
mdeslaurclamav in xenial+ uses the system libmspack, trusty uses
the embedded one.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):released (0.100.1+dfsg-1ubuntu0.12.04.3)
Ubuntu 14.04 ESM (Trusty Tahr):released (0.100.1+dfsg-1ubuntu0.14.04.3)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (uses system libmspack)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (uses system libmspack)
Package
Upstream:released (0.7)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):released (0.5-1ubuntu0.16.04.2)
Ubuntu 18.04 LTS (Bionic Beaver):released (0.6-3ubuntu0.1)
Patches:
Upstream:https://github.com/kyz/libmspack/commit/0b0ef9344255ff5acfac6b7af09198ac9c9756c8
More Information

Updated: 2020-07-28 20:04:04 UTC (commit d26b6ca9f5b3adb89bb036ce73ae7dab894935ec)