CVE-2018-14659

Priority
Description
The Gluster file system through versions 4.1.4 and 3.1.2 is vulnerable to a
denial of service attack via use of the 'GF_XATTR_IOSTATS_DUMP_KEY' xattr.
A remote, authenticated attacker could exploit this by mounting a Gluster
volume and repeatedly calling 'setxattr(2)' to trigger a state dump and
create an arbitrary number of files in the server's runtime directory.
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 19.04 (Disco Dingo):not-affected (4.1.4-1)
Ubuntu 19.10 (Eoan):not-affected (4.1.4-1)
More Information

Updated: 2019-10-18 02:37:37 UTC (commit cccfc4426d8c1fbf582a89d981fe7fc812124543)