CVE-2018-14654

Priority
Description
The Gluster file system through version 4.1.4 is vulnerable to abuse of the
'features/index' translator. A remote attacker with access to mount volumes
could exploit this via the 'GF_XATTROP_ENTRY_IN_KEY' xattrop to create
arbitrary, empty files on the target server.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (code not present)
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 18.10 (Cosmic Cuttlefish):needed
Ubuntu 19.04 (Disco Dingo):not-affected (4.1.4-1)
More Information

Updated: 2019-03-19 11:28:39 UTC (commit 15472795df7e9de45b82f2d36b8b419b939f97b2)