CVE-2018-14653

Priority
Description
The Gluster file system through versions 4.1.4 and 3.12 is vulnerable to a
heap-based buffer overflow in the '__server_getspec' function via the
'gf_getspec_req' RPC message. A remote authenticated attacker could exploit
this to cause a denial of service or other potential unspecified impact.
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 19.04 (Disco Dingo):not-affected (4.1.4-1)
Ubuntu 19.10 (Eoan):not-affected (4.1.4-1)
More Information

Updated: 2019-10-18 02:37:36 UTC (commit cccfc4426d8c1fbf582a89d981fe7fc812124543)