CVE-2018-14652

Priority
Description
The Gluster file system through versions 3.12 and 4.1.4 is vulnerable to a
buffer overflow in the 'features/index' translator via the code handling
the 'GF_XATTR_CLRLK_CMD' xattr in the 'pl_getxattr' function. A remote
authenticated attacker could exploit this on a mounted volume to cause a
denial of service.
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 19.04 (Disco Dingo):not-affected
Ubuntu 19.10 (Eoan):not-affected
More Information

Updated: 2019-10-18 02:37:36 UTC (commit cccfc4426d8c1fbf582a89d981fe7fc812124543)