CVE-2018-14645 (retired)

Priority
Description
A flaw was discovered in the HPACK decoder of HAProxy, before 1.8.14, that
is used for HTTP/2. An out-of-bounds read access in hpack_valid_idx()
resulted in a remote crash and denial of service.
Notes
 leosilva> only affected 1.8.x.
Assigned-to
leosilva
Package
Upstream:released (1.8.13-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):not-affected
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 18.04 LTS (Bionic Beaver):released (1.8.8-1ubuntu0.2)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1.8.13-2)
More Information

Updated: 2019-03-26 12:27:06 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)