CVE-2018-14434

Priority
Description
ImageMagick 7.0.8-4 has a memory leak for a colormap in WriteMPCImage in
coders/mpc.c.
Notes
 mdeslaur> check if im6 commit actually fixes a security issue
 sbeattie> debian claims that it's fixed in 8:6.9.10.8+dfsg-1, but it's
  not
Package
Upstream:released (6.9.10-9)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:DNE (trusty was released [8:6.7.7.10-6ubuntu3.13])
Ubuntu 16.04 LTS (Xenial Xerus):released (8:6.8.9.9-7ubuntu5.13)
Ubuntu 18.04 LTS (Bionic Beaver):released (8:6.9.7.4+dfsg-16ubuntu6.4)
Ubuntu 18.10 (Cosmic Cuttlefish):needed
Ubuntu 19.04 (Disco Dingo):not-affected (8:6.9.10.14+dfsg-7ubuntu2)
Ubuntu 19.10 (Eoan):not-affected (8:6.9.10.14+dfsg-7ubuntu2)
Patches:
Upstream:https://github.com/ImageMagick/ImageMagick/commit/98a2cceae0dceccbfe54051167c2c80be1f13c3f
Upstream:https://github.com/ImageMagick/ImageMagick6/commit/f38d8e7d59abd433b5103c0b35b763e0c793f05d (im6)
Upstream:https://github.com/ImageMagick/ImageMagick6/commit/07b6691bcddfa2f40961a47e9ddfd90edef60dcb (im6)
More Information

Updated: 2019-04-26 14:26:45 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)