CVE-2018-14028

Priority
Description
In WordPress 4.9.7, plugins uploaded via the admin area are not verified as
being ZIP files. This allows for PHP files to be uploaded. Once a PHP file
is uploaded, the plugin extraction fails, but the PHP file remains in a
predictable wp-content/uploads location, allowing for an attacker to then
execute the file. This represents a security risk in limited scenarios
where an attacker (who does have the required capabilities for plugin
uploads) cannot simply place arbitrary PHP code into a valid plugin ZIP
file and upload that plugin, because a machine's wp-content/plugins
directory permissions were set up to block all new plugins.
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needs-triage)
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 19.10 (Eoan Ermine):needs-triage
Ubuntu 20.04 (Focal Fossa):needs-triage
More Information

Updated: 2020-01-29 18:52:08 UTC (commit 40f18bf14da5fb50662e1f861ea594a462b207fe)